Back to overview
Downtime
Microsoft 365 Outage
Jan 25 at 09:42am EET
Affected services
Emails
Resolved
Jan 25 at 10:11am EET
Incident resolved
Affected services
Emails
Updated
Jan 25 at 09:51am EET
Microsoft investigating issues impacting multiple Microsoft 365 services.
Affected services
Emails
Created
Jan 25 at 09:42am EET
We are getting reports of a major Microsoft 365 outage affecting at least Outlook and Teams.
Developing.
Affected services
Emails