Back to overview
Degraded

Connectivity issues with IMAP & POP

May 19, 2023 at 2:13pm UTC
Affected services
SRV-1

Resolved
May 19, 2023 at 2:50pm UTC

We have identified the root cause of the issue.

Created
May 19, 2023 at 2:13pm UTC

Investigating connectivity issues with IMAP & POP for certain users.