Get in touch
Back
Downtime

Investigating Transactional Emails Backlog

Started 18 Jun at 11:04am EEST, resolved 18 Jun at 01:29pm EEST.

Emails
Resolved

The issue is resolved and emails on the backlog will start sending in a while.

No emails are lost, and we are continuing to monitor the situation.

Posted 18 Jun at 01:29pm EEST.
Updated

All transactional emails sent from our WordPress websites end up in the backlog.

We found out this is a technical issue on our provider's side.

We are in contact with our provider to resolve this issue.

Posted 18 Jun at 11:15am EEST.
Created

More info will be available soon.

Posted 18 Jun at 11:04am EEST.